compass Failed to build gem native extension.

I struggled with you same issue for about 3 hours. As of Compass 1.0.alpha19, the requirement is for the rvm version 1.9.3.

There are several uncollected posts, however what worked for me was the following:

  1. sudo gem uninstall sass

  2. sudo gem uninstall compass

  3. rvm install ruby-1.9.3-p448

  4. sudo gem install sass --pre

  5. sudo gem install compass --pre

and that did it. Hope it works for you as well!

安装rvm的方法地址待定明天写

按照rvm的地址 http://www.luqidong.com/share/77.html

无标签
分享到: